安装node-sass时出现一下错误:

gyp ERR! configure error 

gyp ERR! stack Error: EACCES: permission denied, mkdir
'/Users/zhang/Documents/data_insight_yinzhou/data_insight_yinzhou/node_modules/node-sass/build'

gyp ERR! System Darwin 17.6.0

gyp ERR! command "/usr/local/bin/node"
"/Users/zhang/Documents/data_insight_yinzhou/data_insight_yinzhou/node_modules/node-gyp/bin/node-gyp.js"
"rebuild" "--verbose" "--libsass_ext=" "--libsass_cflags=" "--libsass_ldflags="
"--libsass_library="

gyp ERR! cwd
 /Users/zhang/Documents/data_insight_yinzhou/data_insight_yinzhou/node_modules/node-sass

gyp ERR! node -v v10.1.0

gyp ERR! node-gyp -v v3.6.2

gyp ERR! not ok 

查看资料发现,可能需要增加--unsafe-perm,即

sudo npm install node-sass --unsafe-perm --save-dev

成功安装node-sass

 

转自 https://blog.csdn.net/u010963686/article/details/80675240