<> Android app development -01- Development tools and environment configuration

Please choose according to the recommended index and your own wishes

<> use Android Studio

* 1. have access to Android Studio
* Download address :http://www.android-studio.org/ <http://www.android-studio.org/>
* I will not reprint the configuration method , Please refer to :https://blog.csdn.net/jklinux/article/details/77888804
<https://blog.csdn.net/jklinux/article/details/77888804>
* Recommendation Index : ☆☆☆☆
* Tips : It's better to download that compressed package
<> use Eclipse+ADT+Android SDK

* 1. If it is configured in detail , This is more troublesome
* So I provide an integrated one eclipse development tool , You can use it after decompression
* Download address :https://pan.baidu.com/s/1vE6tNAkTz-5C9rSIRpy00g
<https://pan.baidu.com/s/1vE6tNAkTz-5C9rSIRpy00g> password :oq7c
* Recommendation Index : ☆☆☆☆
* Please ignore this section ; There is one thing to pay attention to , Generally, it can be used after opening , If you downloaded it before Android SDK Do not use , To use the compressed package
sdk, Otherwise, there is no solution for version mismatch , So if you turn it on , New Android project , If you report a mistake , Make the following settings
* take SDK Set the path to the decompressed SDK route :

* 2. If you don't want another one eclipse, I just want to be in myself eclipse Upper configuration
* Recommendation Index :☆
* I'll find it for you , Please refer to :https://www.cnblogs.com/zh719588366/p/5928140.html
<https://www.cnblogs.com/zh719588366/p/5928140.html>
<> Environment configuration

* The environment configuration is mainly aimed at jdk Environment variables for , If previously configured , You can also refer to it
* If you've configured it , Make sure there are no problems , Please open it cmd
* Then test :1.java 2.javac 3. java -version 3 Orders
* There is an error in any of the commands , It means that the variable configuration is wrong
<> Configuration variable method

* All addresses are based on their own installation path , You have to match yourself
* 1.JAVA_HOME
* The variable value is jdk The path of :

* 2.Path Add path to variable
* …\jdk…\bin

* 3. New variable :CLASSPATH
* The variable value is :
.;%JAVA_HOME%\lib\dt.jar;%JAVA_HOME%\lib\tools.jar

* 4. Test again :
* Check again if there is a mistake
<> use Eclipse+Tomcat+MAVEN

* If you want to use Eclipse+Tomcat+MAVEN
* Recommendation Index for novices :☆
* Please refer to :http://www.cnblogs.com/Li-Cheng/p/4335418.html
<http://www.cnblogs.com/Li-Cheng/p/4335418.html>
<> Links to more articles : Android app development <https://blog.csdn.net/qq_40147863/article/category/8054657>