问题

今天尝鲜manjaro,当安装完vim却发现无法使用,抛出如下错误
vim: /usr/lib/libc.so.6: version `GLIBC_2.28' not found (required by vim)
显然没这个库,我按装的是manjaro 17 ,百度这个库GLIBC_2.28,发现最近跟新,于是更新系统
sudo pacman -Syyu
一路 yes发现更新失败,
:: Synchronizing package databases... core 147.5 KiB 1378K/s 00:00
[#######################] 100% extra 1796.2 KiB 5.43M/s 00:00
[#######################] 100% community 4.8 MiB 8.92M/s 00:01
[#######################] 100% multilib 180.0 KiB 3.52M/s 00:00
[#######################] 100% :: Starting full system upgrade... ::Replace
compositeprotowith extra/xorgproto? [Y/n] :: Replace damageproto with
extra/xorgproto? [Y/n] ::Replace fixesproto with extra/xorgproto? [Y/n] ::
Replace fontsproto with extra/xorgproto? [Y/n] :: Replace gnome-themes-standard
with extra/gnome-themes-extra? [Y/n] :: Replace gnome-tweak-tool with
extra/gnome-tweaks? [Y/n] ::Replace inputproto with extra/xorgproto? [Y/n] ::
Replace kbproto with extra/xorgproto? [Y/n] :: Replace
manjaro-gnome-extension-settingswith community/manjaro-gnome-extension-settings-
17.0? [Y/n] :: Replace manjaro-gnome-extension-settings with
community/manjaro-gnome-extension-settings-18.0? [Y/n] :: Replace
manjaro-gnome-maia-themewith community/manjaro-gdm-theme? [Y/n] :: Replace
manjaro-gnome-settingswith community/manjaro-gnome-settings-17.0? [Y/n] ::
Replace manjaro-gnome-settings with community/manjaro-gnome-settings-18.0?
[Y/n] ::Replace pkg-config with core/pkgconf? [Y/n] :: Replace randrproto with
extra/xorgproto? [Y/n] ::Replace recordproto with extra/xorgproto? [Y/n] ::
Replace renderproto with extra/xorgproto? [Y/n] :: Replace scrnsaverproto with
extra/xorgproto? [Y/n] ::Replace videoproto with extra/xorgproto? [Y/n] ::
Replace xextproto with extra/xorgproto? [Y/n] :: Replace xf86vidmodeproto with
extra/xorgproto? [Y/n] ::Replace xineramaproto with extra/xorgproto? [Y/n] ::
Replace xproto with extra/xorgproto? [Y/n] resolving dependencies... looking for
conflicting packages... error: unresolvable package conflicts detected error:
failedto prepare transaction (conflicting dependencies) ::
manjaro-gnome-extension-settings-18.0 and manjaro-gnome-extension-settings-17.0
are in conflict
解决


仔细研究了一下,应该这样解决这个冲突,当问到是否替换17.0的时候选择NO,替换18.0的时候选择YES,如果反着来也可以,更新完成。重启最后vim可以正常使用